«前の日記(2013年03月20日) 最新 次の日記(2013年08月31日)» 編集

だめだめ日記

ツッコミの内容は検索サイトからの検索やサイトのレーティングに影響します。そのため問題があるキーワードを含むと思われるツッコミについては、当方の判断で削除することがあります。予めご了承ください。 なお、コメントspamと判断されたツッコミは自動的に消去されます。ご容赦ください。
2002|12|
2003|01|02|03|04|05|06|07|08|09|10|11|12|
2004|01|02|03|04|05|06|07|08|09|10|11|12|
2005|01|02|03|04|05|06|07|08|09|10|11|12|
2006|01|02|03|04|05|06|07|08|09|10|11|12|
2007|01|02|03|04|05|06|07|08|09|10|11|12|
2008|01|02|03|04|05|06|07|08|09|10|11|12|
2009|01|02|05|06|07|08|09|10|11|12|
2010|01|02|03|04|05|06|07|08|09|10|11|12|
2011|01|02|03|04|05|06|07|08|09|10|11|12|
2012|01|05|06|09|10|11|12|
2013|01|02|02|03|08|09|
2014|01|
2015|09|10|11|
2016|01|04|

執筆、翻訳などに関わった書籍類


【改訂新版】Samba [実践]入門

Linux教科書
LPICレベル3 300試験

マスタリング Nginx

実践 パケット解析 第2版

改訂版 Sambaのすべて

アンドキュメンテッド
Microsoftネットワーク

その他の書籍は だめだめ日記のおみせ@本店でどうぞ。



2013年03月21日 [長年日記]

[Samba]Solaris 11 で Samba 3.6.13 をビルドする

以下のオプションをつけることで --with-ads を有効にした状態でビルドできました。

export LIBS="/usr/lib/libldap-2.4.so -lgss"
export CPPFLAGS="-I/usr/include/kerberosv5"

1行目の前半設定がないと、configure 時に Solaris デフォルトの LDAP ライブラリが使われるため、ldap_initialize() 関数がありませんというエラーになってしまいます。

2行目の設定がないと、configure が krb5.h を見つけることができないため、やはりエラーで止まってしまいます。

1行目の後半の設定がないと、今度はリンクの際に GSSAPI 関連のライブラリがないと言われて止まってしまいます。

なお、以下のパッケージを追加インストールしています。

  • developer/gcc-45
  • system/library/iconv/unicode

以下のパッケージも必要だと思いますが、インストール済でした。

  • library/openldap
  • service/security/kerberos-5
余談

パッケージに含まれるファイルの一覧は、以下のようにして確認できました。

pkg contents パッケージ名

Copyright (C) 2003-2017 TAKAHASHI, Motonobu
webmaster@monyo.com